Jump to content

Report a Bug

  • Please log in to reply
27 replies to this topic

Alo8ight #1 Posted 13 January 2016 - 01:10 AM

    Senior Sergeant

  • Players
  • 1810 battles
  • 959
  • Member since:

Update 2.5 has a lot of content to offer and for any big update, come potential issues that any one of us may encounter.


To combat these issues, we’d like to ask the community to keep track of these instances and use the following workflow, when reporting a bug:



The same info can be found at our Support page.

NitroTheCreator #2 Posted 13 January 2016 - 01:15 AM

    Bow Down Before Me

  • Players
  • 44666 battles
  • 3,843
  • [STORM]
  • Member since:
Is the 6,000 credits instead of 3,000 a bug? If so I would like to send in a ticket for that then 

Jack0fAllTanks #3 Posted 13 January 2016 - 01:16 AM

    Senior Sergeant

  • Players
  • 73368 battles
  • 753
  • [S7A]
  • Member since:

My Churhill Gun Carrier can't use it's Universal Camo.  It's purchased and shows in the garage but won't apply in battle.  Thankfully I'm not being charged to resupply it.  I haven't tried the seasons camos yet.


Yes, the Universal camo has worked with my other tanks so far.


Jack0fAllTanks #4 Posted 13 January 2016 - 01:24 AM

    Senior Sergeant

  • Players
  • 73368 battles
  • 753
  • [S7A]
  • Member since:

View PostNitromemania, on 13 January 2016 - 01:15 AM, said:

Is the 6,000 credits instead of 3,000 a bug? If so I would like to send in a ticket for that then 


Advertised as same price as low cost supplies; sold as high cost supply.  Would be nice if it got corrected.


tedg5 #5 Posted 13 January 2016 - 01:41 AM

    Tater salad

  • Players
  • 70977 battles
  • 6,571
  • [AGOGO]
  • Member since:
No universal on my e3 either.

Jack0fAllTanks #6 Posted 13 January 2016 - 01:44 AM

    Senior Sergeant

  • Players
  • 73368 battles
  • 753
  • [S7A]
  • Member since:

My M48 Patton had Universal Camo in battle.  Lost and was charge for auto resupply.  But no Camo in next battle - also with no subsequent resupply charge but what happen to my paint that I paid for at the end of the last battle?


My IS7 has won both it's battles and the camo is working as expected there


thetastypie #7 Posted 13 January 2016 - 01:52 AM

    Blueberry Flavored

  • Players
  • 20536 battles
  • 582
  • [IMPR]
  • Member since:
Make sure you have all 3 slots filled with a camo

Tanks I like: T-43, T34(premium),  Ru-251, Panther M/10, Is-3 Defender

Tanks I want: T-30  Is 4 


Officer of the clan Imperium 


Prywid #8 Posted 13 January 2016 - 03:17 AM

    Senior Sergeant

  • Players
  • 8167 battles
  • 567
  • [III-X]
  • Member since:



1.Got that loading screen. 

2.Also in another game, when I pressed 'fire'

button, I was brought to black screen saying 

'please wait... reloading...' So I had to quit the

game and restart it. After doing so I discovered that

laggy shot ammoracked Panther))))

3.Universal Camo won't install. I mean, I pay for it,

see it on my tank in a garage but there is a plain tank 

in s battle. After battle, credits for camo are not deducted. 

acrisis #9 Posted 13 January 2016 - 03:53 AM


  • Players
  • 22213 battles
  • 14,107
  • [III-C]
  • Member since:

Chat is lagging in battle  / chat buttons not sending when pushed.

Some smartss cussed me out, I try to reply, type text, hit the world button, nothing, back into chat, text still there, world button, text goes out ... I get derped by an su :/ 


            BE     (+)   
>> Desktop mode  =>  + Recent topics   + Staff Posts 
    > WG Bugs & current update   > Feedback  
 > Videos   > Vehicle Bay   > Guides    

 > PingPlotter >  Lag, Packet Loss, Ghost Shells, Networking and more demystified using PingPlotter (free)  
Blitz Community Coalition | Looney Tooners | Triarii | Blitz University | Basic Training | Mentor | Pingplotter Guy

Junk_Fuel #10 Posted 13 January 2016 - 05:25 AM

    Senior Sergeant

  • Players
  • 11580 battles
  • 915
  • Member since:

Still getting copperfield in tier 8s. Me and a toon mate were running American t-34s and encountered this map. 

Tho it has only been once. I'm just letting you guys know

New Sig ^^ Stats


LightSkinRizzKing #11 Posted 13 January 2016 - 05:27 AM

    Community Scumbag

  • Players
  • 33091 battles
  • 3,556
  • [ZR0]
  • Member since:
Will send report but just had a game in tier 10. Obj 140 on copper field.

2 Time Twister Cup NA Finalist

Las Vegas 17/Seattle 18 Mobile Masters Finalist

Spring Season Professional Champion

Too Many Tourney Championship Rings To Count

LE_gend_VI #12 Posted 13 January 2016 - 06:10 AM

    The man, the myth

  • Players
  • 20816 battles
  • 3,333
  • Member since:

I'll send ticket but noticed a premium garage glitch. One area glitches and camo comes off tank then back on.


Game crashed (nothing new) but stopped tracking clan supply points. I was tooned and toon mate kept getting tracked but not me. 20k point difference. 



Psyberius #13 Posted 13 January 2016 - 11:13 PM

    Prestige Worldwide

  • Players
  • 29243 battles
  • 1,570
  • Member since:

Game randomly crashed on the Temple map while I was in my STA-1. I kept trying to reboot but it would not let me back in until the match was over. It kept crashing as it was about to load the map. Im running iOS 8.1 on an iPad Air 2.


Edit: crashes in the same manner on iPhone 6 Plus. Game is virtually unplayable. Please fix. 

Edited by Psyberius, 13 January 2016 - 11:33 PM.

"I have come here to kick @$$ and chew bubblegum.

...and I'm all out of bubblegum."

- "Rowdy" Roddy Piper

tlouie #14 Posted 14 January 2016 - 12:13 AM

    First Sergeant

  • Players
  • 9644 battles
  • 5,665
  • [TAT]
  • Member since:
I am seeing a significant pre-battle delay before entering the match.  This delay only happened on my Nexus 9 device, and not on my Nexus 5x device.

Version 2.3
Both devices fine.

Version 2.4 and 2.5
Delay only on Nexus 9, no delay on Nexus 5x.

The same delay/no delay behavior is seen consistently no matter if I'm on cellular or WiFi.

I've tried all the various Graphics settings in game, no change in delay behavior.

I suspect the difference in chipsets to be the issue.

Both devices are running the latest Android Marshmallow OS stock, not rooted.

bill_allen #15 Posted 14 January 2016 - 09:41 PM


  • Players
  • 3535 battles
  • 26
  • Member since:
I'm using an HTC Android, and after this last update, the game skips and freazing is unreal. Got great internet connection, so it's not on my end. Please fix.

ChiefBigCorn #16 Posted 15 January 2016 - 01:52 AM


  • Players
  • 12107 battles
  • 6
  • [ANIME]
  • Member since:
This bug has been around for a few updates but whenever I zoom in and out of sniper mode my gun is always pointing up. It's annoying as all hell. Can't engage what's In front of me before they pull back.

tristancat101 #17 Posted 15 January 2016 - 01:17 PM


  • Players
  • 15982 battles
  • 6
  • [1775]
  • Member since:

ios 9.2

no backround activity that i could see.(might have had a virus)

CalmSeasQuest #18 Posted 15 January 2016 - 02:18 PM

    Senior Sergeant

  • Players
  • 77239 battles
  • 746
  • [DD]
  • Member since:

Garage tank selection bug - iPad air


This has occurred 3 times in the last day. When in the garage, the tank selection slider is INOP. You are able to select one of the visible tanks, but unable to slide to any of the tanks off-Screen (with many of additional tanks available.) This has occurred in solo, and when tooned.


On one occasion, even after closing Blitz and restarting the game, it still occurred.



The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man. - George Bernard Shaw



scott8659 #19 Posted 17 January 2016 - 06:55 PM

    Junior Sergeant

  • Players
  • 20916 battles
  • 160
  • Member since:
Using an iPad Air 2 with all latest IOS patches.  I'm having an issue with the aiming in sniper mode.  I am able to see a tank that is completely exposed but it never locks on.  If I try to fire without the red lock on it never hits even if it's a clear shot. I suspect it's a bug in the camo. I'm also getting more ghost shells since the update. 

Asiaticus #20 Posted 17 January 2016 - 07:02 PM

    First Sergeant

  • Players
  • 16340 battles
  • 2,871
  • Member since:

I'd like to complain that there are no new chat bugs that I've encountered so far in 2.5. With each update I look forward to the introduction of new (or the return of classic) chat bugs. Who can forget the awesome delete as you are typing bug? Or the almost as good platoon partner can't see anything you type bug? Those made the game unpredictable and interesting.


I think the team in charge of the chat system should get to work on some sort of new screw up for us. I'd like to suggest putting common words such as "the" or "and" into the naughty word filter. Maybe bring back the filtering of "sidescrape." That would be very enjoyable for everyone, I'm sure. With a little bit of work, I think the chat system can be just as good is it always was.


Thanks for listening.

Edited by Asiaticus, 17 January 2016 - 07:06 PM.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users